Time Xpressos - false clip-ins?

TokyoTurtle

Speeding Up
Jun 6, 2013
119
18
38
42
Hi all,

Anybody on this forum us Time Xpressos or iClics (same cleat)? Do you have false clip-in issues? I've been on them for a month and once clipped in they're great, getting clipped in is a bit of a PITA. Seem to hear the click and feel the pedal when I pull up, but my foot does not feel solidly clipped in on occasion. Click out then back in and it's solid, but this shouldn't be happening. So, is it my crappy technique or do others have this issue too?


Cheers
 

hat and beard

Maximum Pace
Apr 3, 2012
381
402
93
Setagaya
YES.
Have you checked your cleats? They wear out ridiculously fast.
I was having the same issue until I changed them out.
It's a shame because I really like the system as a whole, but Time really needs to improve their cleats. Mine wore out after about two months of quite intermittent riding.
 

TokyoTurtle

Speeding Up
Jun 6, 2013
119
18
38
42
Thanks

Yeah I've looked at the cleats, and after only a month they are getting unnervingly chewed up. That's the walking surfaces though, the surfaces that clip into the mechanism look ok. Still, maybe the chewed up walking bit could cause a problem for the clip ins. First time on time pedals so I went through the adjustment period. Maybe with new cleats now it'll be smooth for a while.
 

Musashi13

Maximum Pace
Aug 27, 2012
1,818
1,169
143
43
Ichikawa, Chiba
They have a very bad reputation. I read on one forum that "they wear out as you look at them, you can see them falling apart".

Never used them for that reason.
 

joewein

Maximum Pace
Oct 25, 2011
2,784
1,753
133
Setagaya, Tokyo
joewein.net
Type the words "time expresso cleat" into Google and before you even hit ENTER, the 4th search term suggestion that comes up is "time expresso cleat wear"! That tells you something.